TF 2 fails Help!

Blackbeard

Member
Hey guys, If anyone upgraded to Windows 10 & TF 2 runs please let me know How you did it. I have reinstalled, use the compatibility, tried to start in various modes but nothing...Any suggestions from the Team Fortress Experts?
 

The Mighty Gerbil

Tribe of Judah TF 2 Chapter Leader & CGA Admin
Staff member
Googling, it looks like many others have taken the dip with crash results. Some of them have offered fixes but you've probably already seen them.

https://www.reddit.com/r/tf2/comments/3216d3/how_to_get_tf2_working_on_windows_10_technical/
http://steamcommunity.com/app/440/discussions/0/618456760267746439/#c618456760275257942

Problems seem to be centered around resolution problems and setting it manually but that's likely the "mode" you've already tried.

Sorry BB I'm putting off running Windows 10 until the free upgrade offer gets close to ending so they can get most of the kinks out of it. Other programs are have issues with it too it's not just TF2.
 
Last edited:

Blackbeard

Member
Thanks MG, you are correct, there are a lot of Games and I mean Many that are incompatible with Windows 10 atm. Could be the DX version which seems to crash a lot of other normal games, you did mention one thing I did not try and that was starting the game at the lowest resolution but will attempt it. Windows 10 is faster than 7 or 8.1, loads in 5 - 8 seconds but it is not only games that have Issues, many software has problems as well. Thanks for the Help :)
 

The Mighty Gerbil

Tribe of Judah TF 2 Chapter Leader & CGA Admin
Staff member
Have you tried verifying the TF2 files via steam ? In Steam library<right click Team Fortress<properties<local files< verify integrity of game cache?
 

Blackbeard

Member
Yes I always do that if a game acts up, normally fixes it also but I think it is a Windows 10 Issue & not much to do with Steam or TF 2.

Thanks for the Gerbil knowledge :)
 

Patriot

Active Member
Did you manually check the location (hl2 folder) for the file it is looking for? Have you tried creating that file (with nothing in it) in the location indicated?

There are numerous "solutions" if you do a quick Google search. Couldn't tell you what is the right one. And it looks like 2 you have already tried (re-installing, verifying).
 

Wolfeman

Member
I had the same problem. My laptop runs two video cards. An internal intel HD video card and an Nvidia 425M. The only way I could play was to disable the Nvidia card which caused performance issues as well as overheating of my laptop. I tried all the otehr things people hav listed and finally had to revert back to Win 7.
 
Top